ExplorOz and iPad compatibility

Submitted: Tuesday, Sep 19, 2023 at 22:09
ThreadID: 146279 Views:933 Replies:10 FollowUps:9
We have recently purchased the ExplorOz app to use with our iPad Air 4th generation, model MYGW2X/A, a wifi plus cellular model which is running iOS 16.6.1. It has 64GB of memory with 17.85 still free.
The issues are with the maps. Without any specific inputs from us the map will change from what I consider a normal map with in this case a greenish tinted landscape with roads and tracks generally delineated in red dotted, dashed or solid lines, points of interest marked out in contrasting colours, to a map with pastel shades in a light fawn and roads and tracks almost unreadable in white. Sometimes it all reverts back without any actions from us and sometimes not, at least not in the short term, one time the next day saw it return to normal for a short time.
One other time it went to blue and the speed, altitude and heading readouts went to zero, even though we were on the move.
The only fix that I have found so far is to re start the iPad , then re boot the app and it will run as you would expect for a time, but then it sadly reverts to its useless form. I have had an hour of satisfactory use once but generally it ranges from about one minute to ten minutes before it goes tits up again.
I readily concede that I am no master of this newGPS, but its buggy behaviour has been no help in getting set up comfortably with this app.
We bought it mainly on the recommendation of one of the staff at the TJM at Esperance, who said he far preferred it to any of his other GPSs, and he had quite a few, but so far it has been quite frustrating at times, and to be fair it worked pretty well for about 5 hours as we travelled from Forrest to Eucla, once we got it to change from aeroplane to car travel, for some reason the virtual button didn’t want to play the game and this simple change took about ten minutes.
If anyone has any insights as to what may be going on, and how we fix it, I am very keen to hear from you.
One final thought, both our previous Hema Navigators failed with the screen going like it was being viewed through vertical blinds, which were slowly closing. Perhaps it is some of the screen driving circuitry which has failed and the GPS itself is still functional, so I am wondering if it could be used in conjunction with my newer iPad Pro, which is a wifi only device. If so how do I connect them? Would they essentially be plug and play, or would I be entering a whole warren of rabbit holes? My reason for asking is that the iPad Pro is a newer and probably more powerful device and it certainly has much more memory at 256 GB than my wife’s iPad Air. I look forward to the collective wisdom of the forum on these questions, my thanks in advance.
Back Reply Expand Un-Read 1 Moderator

Reply By: OzzieCruiser - Tuesday, Sep 19, 2023 at 22:58

Tuesday, Sep 19, 2023 at 22:58
Isn't there are help desk you can ask this crap - all this type of posts are killing this forum.
AnswerID: 644444

Follow Up By: Member - Duncan2H - Wednesday, Sep 20, 2023 at 07:30

Wednesday, Sep 20, 2023 at 07:30
Hyperbolic much?
FollowupID: 924548

Reply By: ModSquad - Tuesday, Sep 19, 2023 at 23:39

Tuesday, Sep 19, 2023 at 23:39
ExplorOz Support Contact Details
Moderation is just rules

Lifetime Member
My Profile  Send Message

AnswerID: 644445

Reply By: TrevorDavid - Wednesday, Sep 20, 2023 at 07:17

Wednesday, Sep 20, 2023 at 07:17

Not sure what’s happening with the Air, but wouldn’t hurt to clear the cache. Make sure the iPad GPS has a good view of the sky. The Pro would need an external GPS.

Edit. Rob if you haven’t already, set your maps to offline. Best to have the iPad In portrait mode with buttons up, the GPS is in the top of the iPad.


The post below has 1351 views, hardly killing the forum. It’s been said before, if it doesn’t interest you, don’t bloody well read it and then whinge.

Edit ..now 1370



Lifetime Member
My Profile  My Position  Send Message

AnswerID: 644446

Follow Up By: OzzieCruiser - Wednesday, Sep 20, 2023 at 13:22

Wednesday, Sep 20, 2023 at 13:22
I am allowed to make my point just as you are - so it would seem my point is valid that a help desk is available just for this very problem.

And likewise if you dont like my post - dont read it.
FollowupID: 924552

Follow Up By: TrevorDavid - Wednesday, Sep 20, 2023 at 14:20

Wednesday, Sep 20, 2023 at 14:20
Ahh ha ha ha, that’s me laughing Ozzie.

Yes you are allowed to make your point, don’t recall saying you couldn’t. Hang on I will read it again………… nope I didn’t.

Yes again, the help desk is available for problems, something on facebook, (don’t use it) and this forum as well, it’s all about helping others.

“And likewise if you dont like my post - dont read it”. You finally get it, that will help with the whinging.

1541 now




Lifetime Member
My Profile  My Position  Send Message

FollowupID: 924553

Follow Up By: Allan B (Sunshine Coast) - Wednesday, Sep 20, 2023 at 20:00

Wednesday, Sep 20, 2023 at 20:00
I think OzzieCruiser makes a good point and it is hard to ignore an elephant (or a few in fact) in the room.
What does surprise me is that the EO Forum proprietors suffer having frustrated users airing their difficulties with their purchased product in full view of potential purchasers of that product. I would be diligently ushering them into the Help Desk where they could be assisted in private.


My Profile  My Blog  My Position  Send Message

FollowupID: 924557

Follow Up By: TrevorDavid - Wednesday, Sep 20, 2023 at 20:37

Wednesday, Sep 20, 2023 at 20:37

Both you and Ozzie have a point, happy to acknowledge that……why read it if you're not interested is my point.

A question doesn’t necessarily mean the user is frustrated. No doubt some are, others are simply just asking.

If David & Michelle had concerns I’m sure they would do something about it.

To me Forums are about sharing , helping others.

Rob….. Apologies forgetting off topic.




Lifetime Member
My Profile  My Position  Send Message

FollowupID: 924559

Reply By: Member - Happy Explorer - Wednesday, Sep 20, 2023 at 20:10

Wednesday, Sep 20, 2023 at 20:10
Hi Guys and Ladies

I read this post this morning and decided to think about it throughout the day before replying.
I was interested in this post because I am currently transitioning my ExplorOz app from my iPhone to a new iPad Air. It seems to be working fine but I have not had a chance to do any real tests as yet.
While obviously I am not able to offer any meaningful help to Rob, I am none the less Interested to know what the problem ended up being and what the solution was just for interest and maybe the knowedge may help me and other readers trouble shoot a problem sometime in the future.
I really don't know why Ozziecruiser sees this as such a problem. I scan through the posts ever few days and have a read of the ones that interest me and offer a comment if I have something of value to add.
There is a lot of stuff on here that simply does not interest me like what Engel fridges will fit on a Hilux ute. I really could not care less as I am not likely to own a Hilux ute any time soon. Likewise I am no more interested in the road conditions somewhere I am not likely to be going. Does that mean it should not be posted or maybe I should go on a rant, not at all. It is useful to someone and hopefully will help the original poster.
Someone asked about tyres for a 200 series. I read it and found it helpful as while I have a Prado, I am about to shell out for nine new tyres and was tossing up between more Toyos or another brand. Given the huge amount of support on that thread for Toyos that was the decider for me, the new model Toyos it is.
Really, TrevorDavid has summed it up as I have too. If it doesn't interest you simply don't read it.

Hey Rob, let us know how you get on with your problem, please.

Roy G.
AnswerID: 644452

Follow Up By: TrevorDavid - Wednesday, Sep 20, 2023 at 20:46

Wednesday, Sep 20, 2023 at 20:46
Happy E


I use a iPad Air 4th Gen, a couple of years old. Zero issues.

All I ever do to keep it running smoothly is keep software up to date, clear the cache & do a soft re boot every few weeks.



Lifetime Member
My Profile  My Position  Send Message

FollowupID: 924560

Reply By: Member - McLaren3030 - Thursday, Sep 21, 2023 at 07:07

Thursday, Sep 21, 2023 at 07:07
Hi Rob,

Your questions are quite involved. Can I suggest your log a request with the help desk, David & Michelle are currently travelling, but will certainly reply within a couple of days.


Lifetime Member
My Profile  My Position  Send Message

AnswerID: 644454

Reply By: Member - wicket - Thursday, Sep 21, 2023 at 08:36

Thursday, Sep 21, 2023 at 08:36
I am still using my 2016 ipad pro and have zero issues with eotraveller. Can i suggest that you make sure that you have offline maps selected and you have wifi and mobile connectivity turned off, don’t use sleep mode , keep the ipad always on and only close/sleep it manually.
AnswerID: 644455

Follow Up By: ExplorOz - David & Michelle - Thursday, Sep 21, 2023 at 11:56

Thursday, Sep 21, 2023 at 11:56
You have the given him the correct advice. His description clearly indicates his Map Layers is selected on the online Streets & Paths map (pale, no contrast, white roads hard to see) and then when he drops out of service, the app auto switches to offline EOTopo (which he likes). So he isn't seeing the same map source. Each time he gets back in service the app is switching back to the selected online source which is confusing him.

We recommend when travelling that you switch to use OFFLINE maps, and don't use online maps as this avoids issues in patchy service areas and gives the best map screen performance.

The blue screen only ever occurs if you have online maps selected but get stuck in an area where service is patchy and part way through trying to switch between online/offline map sources automatically the map engine in your device freezes. This never occurs if the OFFLINE map source is selected in the map layers.

On some devices this never occurs though. There are other factors involved.

The app even has a built in prompt to to get you to switch the map layers to the OFFLINE source as soon as you download your HiRes offline EOTopo map pack.

He has not contacted me via the Help Desk or by phone so I could not give him any assistance. Thank you for your response to him.
David (DM) & Michelle (MM)
Always working not enough travelling!

Lifetime Member
My Profile  My Blog  My Position  Send Message
Classifieds: Ultimate Camper

FollowupID: 924565

Reply By: Rob G9 - Thursday, Sep 21, 2023 at 22:37

Thursday, Sep 21, 2023 at 22:37
Many thanks to TD, Wicket and DM for the helpful replies to my queries. Thanks also to Macca and SM for pointing me to the help desk.
We have been busy yesterday and on the move again today, so not much screen time to reply earlier, so please accept my apologies for my tardiness.
The main reason for our difficulties is that we have been thrust into learning a whole new system when our old HN7 died while we were thousands of kms away from home and wanting to go to remote areas over pretty ill defined tracks. I had never seen, let alone used EO before, so there was a steep learning curve with very little time to get a handle on it all. I found it difficult to get started just using the manual, no doubt it has the required info, but for a newby just starting out, it was difficult to find what I was after.
I had disabled wifi on the iPad, but not realised that I could lock EO to downloaded maps when we first started, having been told by the TJM staff member that it would work better if I was in poor internet coverage areas. Unfortunately on the second day I forgot to turn wifi off again after my wife had used the iPad during the last evening, so hopefully now that I have all that sorted, we will have a better run. Tomorrow, we plan to travel to Port Augusta from Kimba, ( a really fantastic free camp), so I will try to do a report for those interested, Roy G, to let you know how we went.
I still have a great deal to learn about driving this app, it is just a shame that we were pushed in at the deep end, in the middle of a long and involved trip. Made even harder being old codgers with no younger brains to point us in the right direction when we started going astray ;-)
I would also like to apologise if my post was in any way inappropriate, I’m new here and have not yet learned the nuances of this forum, and just assumed it was ok to ask for advice for these kind of issues.
Thanks again good folk, I’ll keep you posted as to how we go in due course.
AnswerID: 644462

Follow Up By: TrevorDavid - Friday, Sep 22, 2023 at 09:58

Friday, Sep 22, 2023 at 09:58
Thanks Rob

No apology required, not inappropriate whatsoever. Yes you can ask questions on here. Help desk is probably your first option, but feel free should you wish.



Lifetime Member
My Profile  My Position  Send Message

FollowupID: 924570

Reply By: Member - Happy Explorer - Friday, Sep 22, 2023 at 15:36

Friday, Sep 22, 2023 at 15:36
Hi Rob
Thanks for your sincere reply. Like TrevorDavid, I do not consider your enquiry inappropriate at all. I think you have demonstrated how easy it is to sometimes get a little overwhelmed when trying to sort new equipment especially when our mental energy has priorities elsewhere. It is in those moments that the obvious sort of gets a bit hard to spot.
As for the app, I have been using it for several years off and on and there is still stuff there I have not managed to master properly. I think it is great that you can reach out to the community and get a little support and encouragement.
Enjoy your trip without getting lost
Roy G.
AnswerID: 644466

Reply By: Rob G9 - Saturday, Sep 23, 2023 at 09:50

Saturday, Sep 23, 2023 at 09:50
Thanks HappyExplorer and TrevorDavid for the friendly support. Just a quick report this morning, yesterday everything went well with my maps.
The only issue I had was when we went to leave Port Augusta after a quick restocking at Woolies, the map was perfect but my position cursor refused to move once we set off. I had noted in the manual that a frozen cursor can be an issue with iPads, but had forgotten the details. I fixed it by restarting the iPad, then rebooting EO, then everything worked as expected. At the end of the day when I rechecked the manual, this is a problem sometimes with non cellular iPads, however this one is a cellular model, so not sure what happened there.
From here on in, we are on the black top and on the way home so not much critical need of the GPS, but this will provide me with the opportunity to get familiar with the main features like navigationand tracking while not being under the pump.
Thanks again for your courtesy and help in sorting my problem, greatly appreciated.
AnswerID: 644472

Follow Up By: Member - Warren H - Saturday, Sep 23, 2023 at 13:20

Saturday, Sep 23, 2023 at 13:20
This can happen if the gps stays asleep. There is a fix in the advanced setting I believe. Sometimes my Android system does the same thing. The satellite icon stays orange. Tapping the icon usually re-establishes the link, but you do have to remember to check which can be annoying if you are 20km down the road and realise that you haven't been tracking.
NT Pajero
2007 Goldstream Crown

My Profile  My Position  Send Message

FollowupID: 924579

Reply By: Rob G9 - Saturday, Sep 23, 2023 at 17:09

Saturday, Sep 23, 2023 at 17:09
Thanks Warren, the same thing happened today, but it woke up a couple of Kms down the road , all by itself. The strange thing is, the unit was powered up the whole time, just stationary while we had lunch. Perhaps it needs to detect motion or else it has a nap whilst waiting for some action, a bit like our Red Healer dog.
AnswerID: 644474

Sponsored Links